SainSmart UNO R3 Starter Kit With 16 Basic Arduino Projects Now Available
Help - Can't get SainSmart 3.2" TFT LCD Display+Touch Panel+Shield for Arduino 2560 to work
  • I just got the 3.2" TFT display and Arduino Mega 2560 Shield - put them together with my Mega 2560 and plugged it in. The backlight comes on bright and clear. Then I downloaded and installed the library. I open the SainSmart example code and it compiles and downloads to the board just fine with the Arduino 1.04 software. However, I don't get any display. Please help.
  • @Dominick which example did you try?
    I found the same thing with the TFT3_2_MEGA example, but the ITDB02_Graph16_Demo_Landscape looks cool.
    I believe the second example was developed by Henning Karlsen who has developed set set of great libraries for this and other modules that also demo the touch capabilities.
    Check out http://electronics.henningkarlsen.com/
    The good news with this guys libraries are they are well documented to help with learning.
  • @Ray,

    Thanks for the feedback. Actually that is what I was using (downloaded from a post by a moderator on this site) but your comment, which included the _Landscape prompted me to search some more and I found a reference on the Arduino site to the following:


    // Uncomment the next line for Arduino 2009/Uno
    //UTFT myGLCD(ITDB32S,19,18,17,16); // Remember to change the model parameter to suit your display module!

    // Uncomment the next line for Arduino Mega
    UTFT myGLCD(ITDB32S,38,39,40,41); // Remember to change the model parameter to suit your display module!

    Which wasn't in the code example I was using. Once I changed my code to include this it seems to work fine.

    Thanks for the hint.

    Dominick
  • @Dominick please see the attachment.
    ITDB02_Graph16.rar
    1M
  • @Dominick Your welcome,
    I think we are all still learning with this stuff. ;-)
  • you need to use the Arduino IDE 0023, not another one. Only the 0023
  • you need to use the Arduino IDE 0023, not another one. Only the 0023
  • @Ray Thank you for the reference link!
  • I have it all working fine the current latest Arduino IDE, 1.0.5
    On the sainsmart site it does tell you use only 023, and I tried that initially to test.
    Then I tried the same in 1.0.5 but as is, the compiler complains about errors.

    You need to read that error properly and start to understand what is wrong.
    I didn't really want to use an old version of the IDE so I sought to resolve the issue

    In the Graph16 demo , go into the library files and open and edit both ITDB02_Graph16.cpp and ITDB02_Graph16.h
    In each case you are looking to scroll down a bit for this line which is early in the file :
    #include "WProgram.h"

    You want to replace that with
    #include "Arduino.h"

    Voila it stops complaining it cant find stuff and compiles. Upload and the demo works just fine.

    I did the same with the touch demo , change the library's .cpp and .h in the same way.

    So I have the display, touch and the SD card all up and running perfectly fine in Arduino 1.0.5

    That was not so difficult. I think sainsmart should make these mods and update the downloads offered so it works with current IDE.

    Hope it helps :)
  • @viksahota thank u for ur kindly remind. the Mods have been upload. Please check. Best regards.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with OpenID

In this Discussion